Infinite Sync on Samsung Galaxy Tab A

Infinite Sync on Samsung Galaxy Tab A

While creating a new note, I tried to move it to a different folder, and got the "you can't move a note during a sync" warning. I waited a few seconds and tried again. And again. And again ...

Finally, I went back to the notes list, and got a spinning busy cursor. So I waited. And waited. And waited ...

Finally, I exited Nimbus, and re-opened it. I got the thing where it shows a progress bar across the top of the list, indicating that it's syncing. So I looked at my Notifications panel, and yes, Nimbus was syncing. So I waited. And waited. And waited ...

Eventually, I turned on my screen recorder and waited some more. Then I went back into Nimbus and waited.

Eventually, I force stopped Nimbus, re-opened it, and it gave me the "syncing" progress bar thing for about 10 seconds, and stopped. All of my notes were there.

This "infinite" sync has happened to me a lot on my tablet, but not on my phone. I suspect it's the reason I'm having trouble sharing things to Nimbus on the tablet (an issue which I posted here a while back but couldn't reproduce consistently enough for y'all to solve).

I've attached the video. If you don't want to stare at it waiting for things to change, I switched from the Notifications panel to Nimbus around 19 seconds in, and did the force stop around 2 minutes in.

The tablet is a Samsung Galaxy Tab A, running Android 11. I'm certain it's running the latest version of Nimbus, because when I hit this problem a few days ago, I cleared cache and data, uninstalled, and reinstalled, and then let it do a full sync before trying to use it. It seemed to solve the problem until today, when it hit again and I made this recording.