Strange formatting bug on web version with keyboards that have a dedicated numeric keypad

Strange formatting bug on web version with keyboards that have a dedicated numeric keypad

On a mac the keyboard combo cmd + option + 1 (or 2 or 3) converts to a large (or medium or small) header. This works perfectly on the macOS app and in the web if using the mac laptop keyboard and it also works if using the number row (the number keys above the letters) However if I use the numbers on the numeric keypad, that combination does work in the macOS app but not in the web. I tested using a Satechi wired keyboard for mac and also a Logitech universal keyboard that has both Windows and mac function keys (the K780). Both of those have a dedicated number pad and cmd + option + 1 (or 2 or 3) will work perfectly in the macOS app but will not work in the web. On both of those keyboards if I use the 1 / 2 / 3 on the regular numbers in the number row above the letters it will work.

And yes in case you're thinking I'm having a stupid moment and the number lock is off, I checked that and it's not off, I checked, literally 3 times on both, by typing numbers using the dedicated number pad to make sure and I tested making the large / medium / small header on 3 keyboards: the mac laptop keyboard, the wired Satechi, and the wireless Logitech. I've verified that the keyboard combo to make a large / medium / small header will not work when using the dedicated number pad on an external keyboard.

I have not noticed any problems like this with the external keyboards in any other app and on any other website. I've used the Logitech for 5 years and the Satechi for 2 years.

Anybody else have an external keyboard for mac and noticed the number pad will not work in the web when trying to make a large / medium / small header?

@Nimbus team: Can you test this on a mac please and see if you get the same error and attempt to figure out how to fix it? Thanks